nix-ai/containers/hydra.nix
2024-06-15 21:03:49 +02:00

26 lines
494 B
Nix

{ ... }:
{
containers.hydra = {
autoStart = true;
hostBridge = "br0";
localAddress = "10.23.22.10";
forwardPorts = [{
containerPort = 4444;
hostPort = 4444;
protocol = "tcp";
}];
config = { nixosModules, pkgs, ... }: {
imports = [ nixosModules.hydra ];
networking.hostName = "hydra";
services.hydra = {
enable = true;
openFirewall = true;
aiServers."10.0.70.2".sshUser = "builder";
};
};
};
}